FishUSA.com Fishing Tackle The Fishing Tackle Superstore

Author Topic: Ice auger problems  (Read 290 times)

Brsa

  • Jr. Member
  • **
  • Posts: 2
Ice auger problems
« on: Jan 12, 2021, 04:42 PM »
I have a 2015 eskimo stingray 33cc auger Viper engine. I had it running great before I left the house. We got on the lake and it wouldn't start. I have done everything I can think of. I cleaned the carbs, replaced fuel line and filter. Drained and cleaned the tank, replaced grommets and spark plug. Air filter was cleaned, primer bulb works and everything seems in order. I have good compression, fresh fuel. The only way I can get it to stay running is if I have the throttle held down and slightly pressing the prime bulb continuously. What am I missing that could cause it not to run proper?

ActiveTrapChecker

  • Sr. Member
  • ***
  • Posts: 521
Re: Ice auger problems
« Reply #1 on: Jan 12, 2021, 04:52 PM »
Id ask that question on the sister site Ice Shanty. May get a response there

Brsa

  • Jr. Member
  • **
  • Posts: 2
Re: Ice auger problems
« Reply #2 on: Jan 12, 2021, 04:56 PM »
Will do, thank you.

Raquettedacker

  • MFF Mod Team
  • Sr. Member
  • ****
  • Posts: 8,397
Sometimes we live no particular way but our own.....<br />Strangers stopping strangers just to shake there hand...<br />\"Dying is the easy part. Learning how to live is the hard part....\"

Mac Attack

  • Sr. Member
  • ***
  • Posts: 6,813
Re: Ice auger problems
« Reply #4 on: Jan 12, 2021, 05:58 PM »

fishogger

  • Sr. Member
  • ***
  • Posts: 1,856
Re: Ice auger problems
« Reply #5 on: Jan 13, 2021, 03:54 AM »
ill guess anyhow.  either there is still a chunk plugging carb. fuel pump bad? or check the timing aka keyway---------------- no wait 2015 you said?  who knows probably computer issue? fuel injection issue? I wish you good luck though.  too bad they cant make them simple long lasting machines like the old days.
some fishermen tell lies,  this one doesnt need to

caught_the_fever

  • Jr. Member
  • **
  • Posts: 212
Re: Ice auger problems
« Reply #6 on: Jan 13, 2021, 05:06 PM »
I have a 2015 eskimo stingray 33cc auger Viper engine. I had it running great before I left the house. We got on the lake and it wouldn't start. I have done everything I can think of. I cleaned the carbs, replaced fuel line and filter. Drained and cleaned the tank, replaced grommets and spark plug. Air filter was cleaned, primer bulb works and everything seems in order. I have good compression, fresh fuel. The only way I can get it to stay running is if I have the throttle held down and slightly pressing the prime bulb continuously. What am I missing that could cause it not to run proper?

Shanty your best bet.  This stated, having a similar issue with my Jiffy it could be the ethanol.  If you can get Pure Gas, spend the extra money to get rid of the ethanol.  If that doesn't work, add Stabil ethanol treatment - this resolved all issues that I had with my Jiffy which were present from the moment I pulled it from the box.  No issues since using the additive.

iceman260

  • Sr. Member
  • ***
  • Posts: 513
Re: Ice auger problems
« Reply #7 on: Jan 15, 2021, 08:41 AM »
Sounds like you still have blockage in the carb.

 



Iceshanty | MyFishFinder | MyHuntingForum
Contact | Disclaimer | Sponsor
© 2004- MyFishFinder.com
All Rights Reserved.